Chevy SS Forum banner

1 - 10 of 10 Posts

·
Premium Member
Joined
·
107 Posts
Discussion Starter · #1 ·
I have a 2016 SS. I noticed a few days ago when I got in it that there was a little bit of water on the all-weather floor mats on the drivers side. I could tell that it had been dripping from under the dash. I pulled the panel under the dash and it looks like it was dripping down from where the brake pedal rod goes into the brake master cylinder/booster.

Same thing happened today when I got in the car after my car sat at work all day in the rain. Had about an ounce or so of water on the driver's side floor mat after sitting in the rain. Again dripping for the same area stated.

I check the sunroof drain by pouring water into the channel; water drained out the bottom of the car as it should. My car is not affected by the AC drain problem. I also poured about 3 gallons of water onto the windshield with a bucket and sure enough there were a few drops of water that came through. Wherever the leak is coming from, it is only a slight seepage.

As far as I can tell, my hood latch release grommet is in place as it should be.

I am maybe thinking that one of the grommets in this area has a small leak? Maybe a body seam?

Anyone else ever have this problem that ended up NOT being any other cause (sunroof drain, AC drain, hood release grommet)?

I am thinking that I may try to remove the windshield wipers and cowl and maybe even the wiper motor and try to seal every seam and grommet. Thoughts?
 

Attachments

·
Premium Member
Joined
·
15,024 Posts
Is the rubber boot covering the wiper motor properly ????
 
  • Like
Reactions: z51vett

·
Premium Member
Joined
·
15,024 Posts

·
Premium Member
Joined
·
107 Posts
Discussion Starter · #5 ·
The boot on the wiper motor does look to be on properly and is in good shape.

By the way, details on my car.

2016, Auto Trans, Chevy SS

2nd owner

No accidents

42 K miles

Not under warranty.

Daily driver.

No mods other than VCM intake.

I keep the car in immaculate condition and to date this is the only issue. Only just started happening in the last week as I have had the car for almost 8 months and as far as I can tell there wasn't any leak. I may be wrong on that as I recently put the all-weather mats in and noticed water on them. Could have been leaking all along and I just never noticed because I had the carpet mats in.

z51vett - Yeah, I am going to try to check everything in that area. There looks to be 2 maybe 3 total grommets in that area. Also, thought it could be the windsheild also. I am going to try to remove the cowl and the wiper motor so I can get a better look and have room to work. I will try sealing with RTV in every area where there is a seam. Will also check all the grommets.

Not sure when I can do this; weather is pretty crappy right now and I don't have a garage.
 

·
Super Moderator
Joined
·
14,220 Posts
You mention the aftermarket CAI. Was the Yazoo tube removed but firewall attachment point not blocked off, covered, or plugged?
 

·
Premium Member
Joined
·
107 Posts
Discussion Starter · #8 ·
You mention the aftermarket CAI. Was the Yazoo tube removed but firewall attachment point not blocked off, covered, or plugged?
Yes, I did remove the tube but I sealed it completely with RTV. Definitely not leaking from there.
 

·
Premium Member
Joined
·
15,024 Posts
Yes, I did remove the tube but I sealed it completely with RTV. Definitely not leaking from there.

Oh man I hate people who go ape #$^^& with the RTV.

The kazoo tube fitting on the firewall is my call.
 
1 - 10 of 10 Posts
Top