Chevy SS Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
So today I had some audio upgrades done to my ‘15 by a reputable local guy. I put 2 JL Audio 12’s in the trunk(12W1v3-4). In a ported box 17”deep and 34” wide. I paired the subs to a JL XD600/1v2 amp. I had a bass control knob run and mounted in the knee well. I kept the stock speakers in(for now). And I have to say for the most part, it sounds like ass. I’ve had plenty of systems in my cars but always used 10’s. And always JL’s. And always happy. And also aftermarket head units until now. Is the Chevy Mylink head unit interfering with something? I’ve had twin JL 10’s that pump way more and cleaner bass than these and with more punch. I use XM and AUX as my sources and every song from both had me screwing with the bass/treble/mids to make it sound right. At high volume it’s not so bad, but at lower volume I don’t get much low end. Granted it’s better than before, but something is missing. Is there something I’m missing in regards to the Mylink system in our particular cars? Any sort of digital converters or other electronics that can match up the frequencies and make them work together? Because it’s just a mess right now. I think he just pulled sound power from the rear stock subs. Also, a 17” deep box seems way too deep! Maybe that is why I’m lacking that punch. Plus I have no trunk space now. Any experienced guys or gals out there, please hit me up. Thanks!
 

Attachments

·
Registered
Joined
·
555 Posts
Switch your imputs to pre bose amp not right from factory subs, i have 2 ss’s and the one that was installed post amp (By local car audio guy) even with the switch on high level input (two 12 inch kickers) doesn’t sound as crisp as as wifes single 12 installed like recommended on this site taking signal pre bose amp.
i shut center channel speaker off adjust bass settings to 0 or 1 and fade towards rear some, adjust bass knob depending on music i have on.
 

Attachments

1 - 2 of 2 Posts
Top