Chevy SS Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter · #1 ·
On my 14 SS lately the indicator for the passenger seatbelt not fastened is coming on even though there is nobody (or any objects including cell phones etc.) on the passenger seat. When I plug the seatbelt in the light goes out. FWIW on the mirror the "passenger airbag on" message is always on even if there is nobody in the passenger seat.
I am thinking it may be a bad OPDS (Occupant Detection Sensor), or seat weight sensor.
Any Ideas?
 
  • Like
Reactions: B_i_g_m_n_z

·
Registered
Joined
·
778 Posts
OP - be on the lookout for a 'service airbag' alarm....although I'm not quite sure of the logic in SS where I have had no issues with mine BUT compared to my 08 Silverado it started with an odd occupant warning where there wasn't one in the independent seatbelt display...after a few starts the red airbag-to-face alarm lit on the dash and the information center will scroll 'service airbag system'. I am assuming its the sensor in the seat. It would be a good idea to put seat in full fwd / up position and inspect all wires going up into the seat bottom from the back, make sure nothing stupid dislodging a plug....like a scraper or a crumpled can of beer. Dont go too far with inspection as these connections are not ideal to mess with when 12V is going to them. Also, don't put anything or anyone precious in that seat as without a working sensor, the airbag, belt tensioner system may not trigger when needed.
 
  • Like
Reactions: z51vett

·
Registered
2014 SS, SOLD!
Joined
·
4,316 Posts
On my 14 SS lately the indicator for the passenger seatbelt not fastened is coming on even though there is nobody (or any objects including cell phones etc.) on the passenger seat. When I plug the seatbelt in the light goes out. FWIW on the mirror the "passenger airbag on" message is always on even if there is nobody in the passenger seat.
I am thinking it may be a bad OPDS (Occupant Detection Sensor), or seat weight sensor.
Any Ideas?
Usually thats it, on other gm cars, never seen it on an SS. My Cadillac does that on the left rear seat. I just keep that seat belt fastened until I get around to it.
 
  • Like
Reactions: z51vett

·
Registered
Joined
·
2,892 Posts
On my 14 SS lately the indicator for the passenger seatbelt not fastened is coming on even though there is nobody (or any objects including cell phones etc.) on the passenger seat. When I plug the seatbelt in the light goes out. FWIW on the mirror the "passenger airbag on" message is always on even if there is nobody in the passenger seat.
I am thinking it may be a bad OPDS (Occupant Detection Sensor), or seat weight sensor.
Any Ideas?
I have the same issue, and currently have been buckling the seat belt to get rid of the warnings.
 
  • Like
Reactions: z51vett and willy92

·
Premium Member
Joined
·
1,747 Posts
you aren't laying your cell phone anywhere on the passenger seat are you???...this will occasionally give that warning as well...

Good luck with your cars

Bill
 
  • Like
Reactions: good2go and z51vett

·
Registered
Joined
·
90 Posts
Discussion Starter · #9 ·
Vertebrate Mammal Font Automotive design Automotive lighting

Good Morning everyone, This went away for a while and now the problem has come back. Whenever someone gets out of my passenger seat, the car thinks someone is in the seat and not buckled in.
I am not sure if I need the module (part #6)or the Sensor (part #5). Has anyone had this problem and fixed it by replacing one of these parts?
 

·
Registered
Joined
·
93 Posts
View attachment 288636
Good Morning everyone, This went away for a while and now the problem has come back. Whenever someone gets out of my passenger seat, the car thinks someone is in the seat and not buckled in.
I am not sure if I need the module (part #6)or the Sensor (part #5). Has anyone had this problem and fixed it by replacing one of these parts?
I am having the same exact issues. I can confirm buckling the seatbelt makes the warning go away once it appears which isn't all the time. Funny enough it seams to happen when the car has been sitting in the sun. It's normally parked in my garage.

As far as part #5 goes. It has been out of stock since I have been looking in 2019. In fact I don't think GM is making it anymore so hopefully the aftermarket starts making it. I am not even sure if that is the problem but when I went to the dealer they diagnosed the passenger presence module #5 as being the problem.

Please let us know if anyone figures this out. It is annoying to me although I can live with it for now but really want it fixed.

BTW the dealer said this is not a safety issue the airbag will function as it should but you will still get the warning.
 

·
Registered
Joined
·
1,055 Posts
Bump, looking for a solution. Mine started doing it after a heavy job candidate rode with me to lunch. I'm not looking to replace the sensor, as far as I'm concerned, the airbag can go off if I get in a bad wreck. Can I jump a wire so the car always thinks the seatbelt is connected? Or, does anyone have a spare seatbelt clip sitting around? I may just keep it in the receiver and store it in the glove box when I have a passenger.
 

·
Premium Member
Joined
·
7,427 Posts
Search Amazon for seat belt clips. Some interesting designs there.
 
  • Like
Reactions: TheMealOnWheels

·
Registered
Joined
·
90 Posts
Discussion Starter · #14 ·
I am having the same exact issues. I can confirm buckling the seatbelt makes the warning go away once it appears which isn't all the time. Funny enough it seams to happen when the car has been sitting in the sun. It's normally parked in my garage.

As far as part #5 goes. It has been out of stock since I have been looking in 2019. In fact I don't think GM is making it anymore so hopefully the aftermarket starts making it. I am not even sure if that is the problem but when I went to the dealer they diagnosed the passenger presence module #5 as being the problem.

Please let us know if anyone figures this out. It is annoying to me although I can live with it for now but really want it fixed.

BTW the dealer said this is not a safety issue the airbag will function as it should but you will still get the warning.
I still have not done anything yet. The light has not come back on since my last post. I am still curious if it is the sensor on the unit that fails.
 
1 - 18 of 18 Posts
Top