Chevy SS Forum banner

MyLink and USB...

32317 Views 25 Replies 15 Participants Last post by  Randysitz
I discovered an annoying little detail related to the MyLink system. I copied a bunch of music to a USB thumb drive and tried it in my SS but the car would not recognize the drive. After screwing around for a while I discovered that there seems to be a limit to the size of jump drive. Any USB stick 32GB or smaller (capacity) works fine (USB 2 or 3). A 64GB drive will not be recognized...
  • Like
Reactions: 1
21 - 26 of 26 Posts
If you still have the hard drive, stick it in your freezer overnight and try to see if you can read it. If you are somewhat pc savvy and not afraid of linux, pm me and I can send you some information to download software just to recover data, but it requires command line linux.
It's because the system only recognizes a FAT32 file system and it has a limit of 32Gb. The 64Gb drives use NTFS, which the system will not recognize.
That is correct. The file system must be FAT32. I had trouble with the player not recognizing when I added songs to the drive, or if it did, just putting them at the end instead of the order I had them in. It seems these systems save the data for a device, probably to save indexing time, and that causes the "movement" of data. I found this to be tied to the volume name of the device. By changing the volume name (I use the date) every time I add songs, the system thinks it's a new device and has no problems with whatever sort order I set the device up with.
Thanks Tom and welcome to the forum!
Not according to the 2015 manual (7-36):

File systems supported: FAT32, NTFS, Linux, and HFS+.

The following restrictions apply for the data stored on a USB MP3 player or USB device:
‐ Maximum folder structure depth: eight levels.
‐ Maximum number of MP3/WMA files that can be displayed: 10,000.
‐ Playlist entries must be in the form of relative paths.
‐ The system attribute for folders/files that contain audio data must not be set.

That is correct. The file system must be FAT32.
  • Like
Reactions: 1
Welcome to the forum FloridaTom!
I have been struggling with this too. I have a 1 TB usb drive and was putting my songs on it when it popped up saying I needed to format the drive. Well, I already had lots of music on there but I did. It formatted to exFAT. I wouldn't play in my Tahoe. It will play in my accessory transmitter add on in my old truck. I had a 64 usb in there. The 64 plays great in the Tahoe. It is FAT format. The 1TB probably was too before they tricked me into reformatting. I tried the NTFS format, again wiping out all the music. I couldn't even load any on it then. Then the whole drive wouldn't show up on my computer. I had to spend hours researching how to get it back. I am now back to exFAT. I haven't reloaded it yet. I wanted the 1 TB so I could select by voice what albums to play.
21 - 26 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.