Chevy SS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
All stock 2016 SS. I was on the highway and went to downshift and accelerate. Car fell flat on its face, and accelerator was not responsive. Check engine light came on. Scanned car, p0101 code. (Mass or Volume Air Flow Circuit Range/Performance). All intake tubing intact and tight. Any ideas? Thank You!
 

·
Registered
2014 SS, Heron White, No Sunroof, added OEM spare
Joined
·
3,009 Posts
MAF connector came off, maybe?
 

·
Registered
Joined
·
2,369 Posts
Did the problem repeat after a restart and is ongoing, or did it clear? If it is ongoing, the simple answer is it is time for a dealer visit...you already checked the easy fix.


2016 SSB, stick, hole, spare
 

·
Registered
Joined
·
461 Posts
.......wondering if the MAF was replaced and resolved issue.
 

·
Registered
Joined
·
3 Posts
Probably a broken valve spring same thing happened to me replaced Maf etc Found a thread on another forum that said check valves springs. That is exactly what happened. Easy replacement if you rotate engine so that cylinder is TDC you can use an LS rocker mounted spring compressor and swap it without the valve dropping.
 

·
Registered
Joined
·
461 Posts
I flipped the MAF from 17 SS with random P0101 to 08 Silverado 5.3 "0" LMG motor and SS returned to its bad self and Silverado ran/shifted pretty poor and after 3-4 days flagged a P01075 too rich bank 2. Moist weather. SS continues to run pretty good thru 2 tankfuls of Shell and cooler temps. In my case of the P0101 on da SS, I'm assuming its a bad MAF.
 
1 - 7 of 7 Posts
Top