Chevy SS Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter #1
Guys,

Are any of you having calibration issues with your compass? Mines have not worked in two months and have tried driving in circles. Any suggestions?

Thanks,
Wig
 

·
Premium Member
Joined
·
383 Posts
My 2015 SS would display "CAL" in the compass position of the DIC (lower right corner) after first starting the car. It would turn into a "--" in that position on the display after about 1 minute.

The right most light in the center rear view mirror would also turn to red "On*Star" wasn't working and when I would try to use the GPS it would show my car's location about 1500 miles east of its current location and there was a "GPS" with a slash symbol through it showing no GPS signal.

In my case, the VCIM (Vehicle Communication Interface Module) unit failed and required replacement.

If your compass only displays "CAL" then your problem is different than mine, but it may involve the VCIM.

I hope that helps.
 

·
Registered
Joined
·
102 Posts
Sorry to bump an old thread but I figured instead of making a new one...

My compass started saying CAL today in the DIC and HUD. I can’t find anything in the manual about recalibration. I’ve tried driving in circles like in older Chevys but it didn’t fix it. I’ve power-cycled the ignition a few times also.

My nav works and displays my correct location so it’s just the compass. I’m hoping it’s something else simple.

Any suggestions? Thanks.
 

·
Super Moderator
Joined
·
6,083 Posts
While there are no guarantees, we've had more than a few weird issues correct themselves by unplugging the battery for a few minutes. Worth a shot anyway. Good luck.
 

·
Registered
Joined
·
102 Posts
While there are no guarantees, we've had more than a few weird issues correct themselves by unplugging the battery for a few minutes. Worth a shot anyway. Good luck.
So it corrected itself before I even unplugged the battery.

I had been corresponding with White Auto (who does our Holden DIC and radio conversions) and he said that he believes the compass is handled through the Onstar module (VCIM mentioned above). He wanted me to check if my Onstar light was red as that would be a good indicator. It had been sitting in my garage for about 10 minutes since I just got home (and it wasn't working when I shut it off) so I went out and started it up to check my Onstar light. The compass was working again.

So for some reason it began working again after a longer power cycle. If these are the signs of it beginning to fail, at least I know what to look for now regarding the Onstar module.

EDIT: not sure why it autocorrected to Whiteline Auto
 

·
Registered
Joined
·
102 Posts
Well bummer. It worked for about 10 minutes this morning and then displayed CAL. Letting it sit with the battery disconnected didn’t fix it either.

The OnStar light on the mirror is green. OnStar works. Nav works.

Since I hate going to the dealer, does replacing the VCIM requiring programming or plug and play? Also where is it located? Thanks.
 

·
Registered
Joined
·
50 Posts
Our compass just started displaying CAL and the GPS not working as well. Dealer diagnosed a failed module that solved problem.
 

·
Registered
Joined
·
102 Posts
Mine starting working again since the last post and I’ve driven it another 1000 miles with no problems with compass, nav, or onstar so who knows.

Does your work order say anything about programming the new module or just the module and installation? And what part number?
 
1 - 9 of 9 Posts
Top