Chevy SS Forum banner
141 - 143 of 143 Posts

·
Super Moderator
Joined
·
4,370 Posts
inhave 2018 ss with 6.2l that has a 2.9l whipple it also has a horrible rattle sound at idle only. I spoke to whipple charger sales/service and he sent me out a coupling kit saying that would fix the noise but it did not and honestly it’s pretty f'ing annoying to me I’mready to rip it off and go back to stock
Welcome to the SS Forums @Blue2018ss !!

This is a major Zombie thread resurrection!!! The member you quote has not logged on here in over 2 years now!!

That said,,, good luck with the Ghost in Your Machine!!!

ES
 

·
Super Moderator
Joined
·
14,642 Posts
And while we're welcoming you to a forum focused on the 2014 -2017 Chevy SS Sedan, just a heads up that we're a little stricter about foul language than most forums, Especially the f-bomb and various epithets that are all too common in society.
We try to keep this one a bit more whole-family friendly. Hope you can appreciate that.
 

·
Premium Member
Joined
·
247 Posts
So I finally have it underway. I’m about 1/3 of the way done. I keep tripping myself up on how far I want to go with it. My big hang up was on the balancer on whether to use the two pin through the front or use an ATI style pin that goes in at a 90. I decided on pulling the balancer and doing the ATI style pin so if I pull it later I won’t have to drill multiple holes in the snout of the crank.

Please excuse the mess. I just moved to this house and still have a lot of unpacking to do.
Okay, you win the BEST POST OF THE DAY contest (if we had one of those). Winning line - ..."excuse the mess."
Dude, so many people don't post pics, and far fewer attempt the Whipple install themselves. Well done bud.
 
  • Like
Reactions: wilkin4
141 - 143 of 143 Posts
Top