Chevy SS Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a issue with my trailblazer ss. It shuts off while I am drive. I unplug battery for 5 minutes and restart everything and it will run for 30 to 50 miles and then shut off again .. I have replaced ignition switch..throttle body and also computer.. still have issue. Also battery is good ..please help.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
My trailblazer 2007 Ss shuts off while driving ..I then get out and disconnect the battery for 5 minutes and it will start back up and drive for a few days or so then shut off. I have recently changed the ignition switch..throttle body and computer ..I dont know what's going on. Please help
 

·
Registered
Joined
·
172 Posts
Well, this is the Chevy SS Sedan forum so people here won’t have too much knowledge about the Trailblazer SS... some good knowledgeable people might be able to help, but you might be better off trying to find a Trailblazer forum...

Also, a dealer should be able to diagnosis it for you.

Good luck with the problem!
 

·
Registered
Joined
·
172 Posts
Well this is Chevy SS Sedan forum so this is not the best place to look. There might be some knowledgeable people here that might be able to help, but you would probably be better off trying to find a Trailblazer forum...

Also, a dealer should be able to diagnose your problem for you.

Good luck!!
 

·
Premium Member
Joined
·
14,300 Posts
... am I seeing double or what ???
 

·
Registered
Joined
·
955 Posts
My trailblazer 2007 Ss shuts off while driving ..I then get out and disconnect the battery for 5 minutes and it will start back up and drive for a few days or so then shut off. I have recently changed the ignition switch..throttle body and computer ..I dont know what's going on. Please help
Well wrong forum but..... does it have any codes? Check Engine Light on?
 

·
Super Moderator
Joined
·
5,596 Posts
What do you have hanging from the ignition key lots folks had junk on key rings shutting cars off bad ignition switches. GM long time ago had recalls in 90s over this.
z51vett
Doug
 

·
Super Moderator
Joined
·
13,498 Posts

·
Registered
Joined
·
175 Posts

·
Premium Member
Joined
·
248 Posts
I have a issue with my trailblazer ss. It shuts off while I am drive. I unplug battery for 5 minutes and restart everything and it will run for 30 to 50 miles and then shut off again .. I have replaced ignition switch..throttle body and also computer.. still have issue. Also battery is good ..please help.
I had the same problem on my 2007 Trailblazer SS. Its an internal open circuit inside the underhood fuse box. When it gets hot, it opens - turning off the PCM. After it cools down, the wires touch again and it will start right back up.

Try searching on youtube for videos of the fuse box disassembly .. I was able to repair mine for 20 cents worth of solid copper doorbell wire that was the same gauge as the original circuit. The wire on the far right has a break at the bend.
280887
280888
 
1 - 10 of 10 Posts
Top